hello Mr
in the beginning my desktop computer specification is
mother board H55 s2h
bios h55d2h
CPU core i3
internal dvdrw
external dvdrw
monitor LED LG 19"
ordinary power supply 400 watt
HDD 1 Terabyte western digital
i was installing a program on my PC when suddenly the screen is jammed i heard a clicking sound from my HDD so i restarted my pc so the pc took along time to work so i restarted it & i checked the hdd from dos by HDD regenerater that showed about 600 bad sector & fixed then i installed the windows & programs without any problem
after a week i checked the hdd again for any future problems with hdd regenerater from dos & it showed no problem in the hdd then i stated up my computer so it took along time to launch window & show icons
so i bought a new HDD from same type 1 Terabyte western digital & i took my PC to an expert to check the new HDD & install windows so he said your PC is working very well
after 2 days when i was installing a program the new HDD made a clicking like sound & i immediately turned off my PC & checked my hdd from dos with hdd that showed a bad sectors in the beginning of the check
before a week i swapped the the cable of hdd with dvd rw so hdd is worked normally but dvdrw is burned immediately
so where is the problems in hdd or power supply or motherboard
i checked power of pc parts by hw cpuid program
& from bios as below IN THESE LINKS

& i visited power calculating in this site & its calculated my device wattage 360 watt
some friends sayed it may be aproblem in the voltage unit in my motherboard which gives unstable voltage to rams & vga &hdd
i visited the gigabyte company to discuss the problem so they adviced me to update my bios