Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Liquid not getting through...

  1. #1

    Liquid not getting through...

    Hi all,
    I have built a new rig and its looking very tidy (which is a change for me) but the liquid isnt getting through. I have tried (before I added the hardware) shaking, turning it upside down, on its side's and all sorts.

    When I first turned on the pump the liquid wooshed through till it got to the CPU block - I had to take the block apart before to put on the i7 bracket and may have incorrectly re possitioned the little plate thats inside. Now I have ordered another block which should arrive soon (the old one did have a few lumps of green copper type stuff on it any way which I got rid of) but are there any other things I can try?

    Yes that is a sock on the water block - I just dont want to take the block off yet until the new block arrives.


    Thanks again all,
    Brian

  2. #2
    The Main Man Dewayne's Avatar
    Join Date
    Mar 2006
    Location
    Arizona
    Posts
    3,646

    Liquid not getting through...

    Was it a used block or new? If it was old it could of had some junk inside and clogged up the ports. Some Vinegar could help clean it. Other than that you put it back together wrong

  3. #3

    Liquid not getting through...

    It is a used block, I have a new one on the way. There was a bit of gunk in there, but I cleaned it out. There is also some kind of metal plate in the block which I may have put back in the wrong way round. I was just thinking that there might an air lock in the radiator or something wrong with the way I have set the loop up?

    Brian

  4. #4

    Liquid not getting through...

    Without having the piece in hand it's almost impossible to know what is wrong. It could be trapped air, but that would still only cause hot spots, the water should still flow. If it's completely blocked then I'd say you put the thing back together 90 or 180 degrees from normal. It's possible sometimes as the blocks are usually square and the holes re-align.

    The rig looks really nice. It should run super cool with all the work you put into it. Good luck.

  5. #5

    Liquid not getting through...

    This should work when the new block is in place then. I really must have foobar'd the waterblock plate thingy!! Maybe it slipped when I plonked the case into it's area on the desk? Oh well, another point learnt for the future

    Must say though that the Asus's BIOS system is freakin awesome. Its amazing using the mouse in BIOS!!

    Thanks for the help and advice,
    Brian

  6. #6

    Liquid not getting through...

    Finally got around to taking the CPU block off, and found the problem. I have buggered it up, I cleaned off the barbs, and tried to blow though it but I have managed to almost completly block the block!!

    Lesson identified - pay attention when taking apart water blocks with little plates in them!

    New block should arrive tomorrow, I wont try fixing this one as I have no more seal's left for it.

    Thanks again all,
    Brian

  7. #7

    Liquid not getting through...

    Rig running like a dream now! Pics and video to follow once windows has had all its updates!!

    Thanks again all,
    Brian

  8. #8

    Liquid not getting through...

    I think you made a mistake when you mounted the sock. LOL jk

  9. #9

    Liquid not getting through...

    lol And here's me thinking a sport sock would improve the "running" of the machine!!

    Brian

  10. #10

    Liquid not getting through...

    The new build is up and running...



    Enjoy,
    Brian

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to liquid cooling
    By Sebastián Greco in forum Air Cooling/Water Cooling
    Replies: 0
    Last Post: 12-09-2014, 07:33 AM
  2. First Time Liquid Coolng
    By Shodan in forum General Modding Talk
    Replies: 19
    Last Post: 03-25-2010, 09:22 PM
  3. Recommendations for Liquid Cooling?
    By Shodan in forum Talk Freely
    Replies: 2
    Last Post: 08-24-2009, 03:59 PM
  4. TribalOVERKILL's LiquiD EVOLUTION
    By tribaloverkill in forum Modding Work logs
    Replies: 391
    Last Post: 10-01-2008, 04:41 PM
  5. Liquid cooling system, noisey?
    By Virtual-Slay3r in forum Modding Questions
    Replies: 13
    Last Post: 01-07-2007, 06:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •